Issue loading guest journey urls
Incident Report for Superhog
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 17:58 UTC
Investigating
There is currently a problem with loading urls for the guest journey. We are monitoring this and will update asap
Posted Apr 04, 2024 - 16:07 UTC
This incident affected: Superhog (Verification Tool).